One of the issue on linux with mysql-workbench is linked to Python.

  1. First, check the requirement list is depicted on mysql-workbench page for the supported platforms.

  2. On CentOS, you could have installed it using yum and remi repos. If this is the case, reinstall it: yum —enablerepo=remi reinstall mysql-workbench

  3. If you installed it using the tar.gz package, check that you have the following Python package for the linux version: python-paramiko if you use pip: pip install paramiko if you use setuptools: easy_install pycrypto easy_install paramiko

Let me know if it works for you.